Key Management Software

Installation and
Technical Tips

This text deals with the Key Organizer program’s technical
aspects. For notes on the daily use of the program, please
read our separate user guide.
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Simple Installation
There are no special requirements for the installation of the Key Organizer software on a
standard PC. You only need a conventional Windows-PC.
System Requirements:
– PC with Windows® 10, 8, 7, Vista, XP, 2000 or Windows Server
– Screen resolution: 800 x 600 pixels or higher
– Hard disk: 7 MB for the program installation, plus space for your own data/entries
– PDF-Viewer for the user guide, e.g. Adobe® Reader
Optional: To print individually designed receipts in Word-format, you will need to have
Microsoft® Word 2000 or higher installed on the PC from which you want to print.
Installation:
If your program version is stored on a CD, please use the file “Setup.exe” from the CD.
Otherwise, please use the file you downloaded from the internet. If you use the downloaded
file and your operating system is Windows Vista, please make sure that the setup file name
contains the word “Setup”.
You only need to install the program once. After the program installation, there will be new
shortcuts on your desktop and in the program directory. Click one of these shortcuts to run the
program. Once you have installed the program, you will no longer need the CD. However, we
recommend you keep it anyway.
By the way, you can use the free demo version to test the network and multi-user compatibility. For more information, please read the section “Network Installation”.
Directories:
If you have administrator rights (recommended), use the regular program directory (“Program
Files”) to install the program. Otherwise, use the folder “My Documents”.
The default directory for the program installation is ...
C:\Program Files\KeyOrganizer\
You can change the directory during the program installation. It is even possible to install the
program on a mobile device, e.g. a USB drive.
The setup creates the data folder in the program directory – by default, this is
C:\Program Files\KeyOrganizer\Data\
If you are familiar with your PC’s folder structure, feel free to choose a more suitable data
storage location in the program settings. This could e.g. be a server. We recommend this
particularly for backing up your data.
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FAQ and Technical Details
Do I need additional programs or drivers?
No. The program contains all necessary functions, e.g. an integrated database (see below).
You will only need an additional driver if you use a signature pad.
Key Organizer on Mac or Linux?
With WINE, you can use the Key Organizer under Linux. For Mac OS X, there is a commercial
WINE variant called CrossOver.
What kind of database does the Key Organizer use?
The program uses its own fully integrated database. This means that you do not need to have
e.g. Microsoft® Access or any other additional program installed on your PC. It also means that
you do not have to pay for additional software licenses and that the Key Organizer can be used
on any Windows PC. This way, we can guarantee that you will never have version conflicts with
the database.

Rare Problems
Problems printing with Microsoft® Word
A few of our customers had problems using Word for printing receipts. They received the error
message: “The stub received bad data”. If you come across this problem, please use this
Microsoft Office Bugfix: http://www.joerg-rosenthal.com/en/word-stub.html
The message “Data record is locked for editing by another user“ is displayed
If this message is displayed without any reason, i.e. if the displayed user is not even logged in,
you will have to unlock the data record manually. There are two possible ways you can do this:
The displayed user logs on to the program from his(!) workstation and re-opens the data
record for editing. After that the data record should be unlocked again.
The other possibility is to delete the lock file. To do so, open the Key Organizer’s data directory
in your Windows Explorer, e.g. by selecting the button “Display” under Edit > Settings > Files
> Data Directory in the program menu. Exit the Key Organizer and delete the file “Data.wpi”
(should have a size of 1 kb) from the data folder. This will unlock the data record.
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Network Installation
With the Key Organizer, you can access your shared data pool from several PC workstations at
the same time. Please note the conditions for purchasing licenses for network users (see
chapter Licenses).
You do not have to install a database engine on the server, because the Key Organizer
organizes his multi-user capable file storage independently. The program needs a shared folder
on a file server. The program does not support web servers, i.e. the protocols HTTP or FTP.
By default, the Key Organizer setup installs a single workstation, i.e. the program and the
folder containing the data are usually stored on the local hard disk in the program directory,
e.g. C:\Program Files\KeyOrganizer\Data\
1st Option:
Several local installations

2nd Option:
One central installation

You install the Key Organizer locally on
every PC on which you want to use the
program.

You only install the Key Organizer program
on a server once. The clients will start the
program directly from the server (e.g. using
a shortcut icon).

You will need a shared folder on a server
that can be accessed and used as a shared
data directory by all Key Organizer installations.
Select the shared data path in every local
installation of the Key Organizer. You will
find this setting in the program menu under
Edit > Settings ... Data Directory ...
“Change” button.

You can also run the program using a
terminal server.
If you wish to change the data path, please
note that the path description must be the
same for all clients, and must be accessible
for all clients. For example, it should be in
UNC format \\Server\Key-Organizer-Data\
and not a local path as C:\...

The server does not have to be a WindowsPC. We have successfully tested sharing
folders using the Samba-FileServer under
Linux. The Key Organizer program itself,
however, is a pure Windows application.
Folder access: All users who are supposed to use the Key Organizer must have read and
write access to and delete rights for the data directory. This also applies to users who will not
be assigned change access to the program. The Key Organizer controls its users’ authorizations
automatically.
Windows user names: Please note that each Key Organizer user must be logged on to
Windows with an individual Windows user name.
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File Storage and Moving of Files
The default directory for the program installation is ...
C:\Program Files\KeyOrganizer\
You can change the directory at the program installation. It is even possible to install the
program on a mobile device, e.g. a USB drive.
The setup creates the data directory in the program directory – by default, this is
C:\Program Files\KeyOrganizer\Data\
If you are familiar with your PC’s folder structure, feel free to choose a more suitable data
storage location in the program settings. This could e.g. be a server. We recommend this
particularly for backing up your data.
Transfer Program and Data to a New PC
When replacing a PC, you will have to
transfer all locally stored data from the old
PC to the new one. If you have not stored
your data on a server, this also applies to
the Key Organizer.
Compared to the transfer of other
databases, moving Key Organizer data is a
piece of cake. You only have to copy the
data directory, for example to a USB stick or
a network. Although this is a very simple
process, it should still be done by someone
who is familiar with the Windows Explorer
and the directory structure on the hard disk.
Steps:
Install the Key Organizer program on a new
PC. To do so, use the program CD or,
preferably, the latest download file you
received from Rosenthal Software.
After the installation, an empty program
without any entries will be installed on your
PC. Shut down the program.
Copy your data from the old PC to a data
carrier, e.g. a USB stick. By default, the
relevant data (on the old PC) is stored in the
following directory:
C:\Program Files\KeyOrganizer\Data\
We recommend you copy the entire
subfolder “Data”, together with all data it
contains, and all subfolders.

Then copy the folder “Data” to the program
directory
C:\Program Files\KeyOrganizer\Data\
on your new PC. It will replace the already
existing folder “Data”. If Windows asks you
if you want to overwrite the folder or the
data, confirm this with Yes.
Start the Key Organizer on your new PC,
and check if your entries are displayed
correctly. If so, the transfer was successful.
If not, close the program and check if the
directory structure
C:\Program Files\KeyOrganizer\Data\
is complete. You can do this by using the
Windows Explorer to compare the files on
your old PC with the files on your new PC.
Please also check if the displayed entries are
up-to-date, e.g. by checking if the latest
entries you made are still there. We received
some calls from customers who, in the
course of time, had created several data
directories (manual copies) and then could
not remember which one was the newest.
You can find copies of the folder by using
the Windows file search and searching for
“Data.ada” on your hard drive.
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Several Databases
Most of our customers do not need more than one database for their key
entire key management is intended to be stored centrally - and most
consider this to be an advantage. In addition, the database is designed
master key systems for any number of buildings. Therefore you usually do
more than one database.

management. The
of our customers
to store up to 40
not have to create

You can, however, create several databases if you e.g. want to manage individual data pools
for your subsidiaries on a central server. To do so, create a data directory for each subsidiary,
e.g. \\Server\KeyOrganizer\Branch1\
You can create individual program shortcuts for the relevant users to make sure that the Key
Organizer is started with the correct database. The prompt could then for example be:
[Program folder]\Start.exe "DataPath=\\Server\KeyOrganizer\Branch1\"
The databases are completely independent of each other, i.e. each database has its own user
administration and e.g. also its own employee master data (as key recipients).
The Key Organizer does not yet contain a function for the combination of several databases,
e.g. with cross-database employee master data. It is also not possible to merge the databases
to one database.
The storage locations do not have any effect on the licenses, which means that you will still
have to purchase a main license for each legally separate enterprise, and to account for the
relevant number of PC workstations.
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User Authorizations
The Key Organizer contains an integrated user administration function where every user can
create and change their own password. You can use the user administration to determine the
individual users’ authorizations, i.e. which program function they will be allowed to use.
The program installation does not automatically create users. As long as you have not defined
users, everyone can log on to the program without having to enter a password.
You will find the user administration in the main menu of the Key Organizer under Edit >
Users.
Once you have entered and saved a user, you can use the button “Authorizations” to define the
relevant authorizations.
Only users with an active authorization for “Users + User Authorizations” are allowed to
change other users’ authorizations and passwords. The program makes sure that users cannot
lock themselves out by automatically granting special rights to the remaining users.
If you lose an important password and are unable to change it, please contact the software
supplier (info@joerg-rosenthal.com) to request the master password for your program version.
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Data Import
We want to spare you the burden of having to enter your data manually (or at least keep it to
a minimum). Therefore, the Key Organizer contains various import functions, in particular for
Excel lists. You will find the import functions in the main menu of the program under File >
Import.
For lists, e.g. key lists or employee lists, we recommend you use the “individual import” which
offers you the possibility of customizing your table’s columns.
For locking plans (with a locking matrix), please use the function “Import Excel locking plans”.
Prior to the import, modify your Excel table’s columns according to the sample locking plan.
You can download the sample locking plan from the download section of our Key Organizer
homepage.
If your master key system is relatively new, your locksmith will probably be able to provide
you with the appropriate locking plans as an Excel table. You can also use the file types .KWD
(a special file format for master key systems) or .XML (data exchange format). Due to several
format differences, we cannot guarantee that all .KWD and .XML files can be imported.
Send us files to test import
Since the form of your existing data or files may vary considerably, we offer you the possibility
of sending us your files - even before having purchased the software - to test if they can be
imported and to provide you with support. There will be no additional costs and this service is
not binding.
Please send us an informal e-mail with your existing data (locking plans, lists, tables, data
bases, etc.). We will check if your data can be imported into the Key Organizer - for free and
as a non-binding service.
Data Update
The import functions are generally designed for a one-off import, i.e. after having imported
lists you will have to make subsequent changes in the Key Organizer. Larger companies with a
high number of employees should, however, regularly synchronize their data with the
company’s official list of employees. For this, the program provides a special function (see next
page).
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Regular Import of the Latest List of Employees
If you use a software application for the administration of your employees’ data, you may be
able to transfer its data to the Key Organizer at regular intervals to keep the list of persons in
the Key Organizer up-to-date automatically.
As a prerequisite, you will need a simple table with the employees’ names; preferably a
CSV-/text file with tab-separated values.
To automate the data transfer as much as possible, the Key Organizer knows certain call
parameters, causing it to import the table automatically.
Call by Prompt
The prompt call for the Key Organizer is ...
KeyOrganizer.exe multistart autoLogin=XXX "autoImport=C:\Path\ImportPersons .ipo"
You will find your personal autoLogin parameter in the Key Organizer window “Settings”. To
open this window, select Edit > Settings > Other in the program menu. Note that the
autoLogin parameter is user-specific and changes as soon as that user’s password changes.
The autoImport parameter refers to an .IPO file (containing import settings). If you are
interested in this file, please let us know (e-mail: info@aidex-software.com) and we will be
glad to send it to you.
Use the autoImport parameter to define the storage location of the IPO file. If the path
description contains a space character, the phrase must be put in quotation marks.
After the import (which - depending on the number of people - can take just a few seconds or
several minutes) the program shuts down automatically.
Error log
The Key Organizer can create a log file, listing errors that occur during the import. This will
help you to locate a possible error.
If you would like the Key Organizer to create an error log, manually enter the following line
into the file KeyOrganizer.ini in the Key Organizer’s program directory:
ErrorLogFile=[Path\]Filename.txt
You can also let the Key Organizer log successful imports ...
SuccessLogFile=[Path\]Filename.txt
If you want to have all logs in one file, you can also enter the same file name for both
ErrorLogFile and SuccessLogFile.

9

Data Backup
Integrated Data Backup (Out-of-Date)
The Key Organizer provides a simple integrated data-backup function which creates copies of
the most important data files. However, these copies do not comprise all data, and are also by
default stored on the same hard drive as the original data. If your hard drive is defective, you
will lose both the original and the backed-up data. Therefore we recommend you use a
different kind of data backup, if you have the possibility of storing the data on a server with an
individual data backup option.
Outsourcing of Data to a Server (Recommended)
We recommend you outsource the Key Organizer’s data directory to a file server. To do so,
manually move the “Data” directory from the program directory to the server. Then enter a
new data path in the program settings. For more information, please read the section “Network
Installation”.
You do not have to consider anything in particular when backing up your data. Please save the
entire data directory, including subfolders. You can even use the Key Organizer and backup
data at the same time.
You can switch off the integrated data backup by selecting “manually” in the Key Organizer’s
settings.
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Licensing
As is customary for standard software, the purchase of a software application not only implies
the purchase of the source code or the executable program, but also comprises the purchase
of a license for use of the program (use license). Please use the following link to read our
license agreement: www.aidex-software.com/en/key-organizer/licensing.html
The license agreement will also be provided together with the program and must be confirmed
by each user before using the program.

License Model
The first license, i.e. what is called Variant 750 etc. in the price list, is valid for one PC
workstation. One or more users are allowed to use the Key Organizer at this PC. You are,
however, not allowed to use the program from another PC.
If you wish to use the Key Organizer on additional PCs, you will have to purchase a license for
every additional PC from the second PC. We offer these additional licenses at a very favorable
price.
The same applies to the use of the Key Organizer via a terminal server. In this case, the
number of licenses depends on the number of terminals/client PCs from which the program will
probably be called. If you cannot assess this number, the number of licenses depends on the
number of Key Organizer users, based on the assumption that, nowadays, most users have
their own PC at their workplace.
You do not have to purchase licenses for holiday replacements or special use of the program,
e.g. for a one-off data gathering from a separate PC.
For example: Full-time employees A and B are supposed to use the Key Organizer regularly
from their PCs. Employee C is a temporary employee and uses B’s PC. Employee D is a holiday
replacement and works in the office next door. Prior to this, employee E collected all data on
his laptop in one single session.
In this example, you only count A’s and B’s PCs, although the Key Organizer is also available
on D’s and E’s PCs. That means that beside the main license (e.g. Variant 750), you have to
purchase one additional use license for the second PC.
There is a fixed price for the additional user license, which is independent of the variant with
which you purchased a main license.
For franchise chains with legally separate subsidiaries, every subsidiary has to purchase its
own main license, i.e. it is not possible to purchase the discounted additional licenses for other
companies. In exceptional cases, it is possible to close an alternative, individual agreement.
We also would like to mention that the majority of our customers consider the one-off price for
the Key Organizer to be very favorable. We offer the additional user licenses practically for a
song. Our software does not include call monitoring or license key queries. We will therefore be
all the happier about your fairness, and appreciate your purchase of additional licenses if you
need them. Thank you very much!
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Program Updates
We continuously improve the Key Organizer. In addition to the program improvements, we
regularly add new functions upon request of our customers. Click the following link for a
summary of all enhancements:
www.aidex-software.com/en/key-organizer/update.html
If you are still testing the trial version of our key management software, feel free to download
the latest version from our homepage. To install a newer version, simply overwrite the existing
installation with the new trial setup. This will not change any of your existing data.
If you are our customer already, and own a purchased program version, please send us an email if you wish to receive a customized program update (this is free in the first 12 months
after your purchase).
Please do not use the trial version from the internet as an update, because this will downgrade
your purchased version to a trial version and you will not be able to enter additional data
records (your existing data will not get lost).
You will not have to update the Key Organizer regularly – in contrast to e.g. virus scanners
with a daily update requirement, or tax calculation programs that must be updated annually
due to the changes in legal regulations.
If you are interested in program updates for the Key Organizer anyway, for example because
you are interested in a new function, you can purchase an update-year when your first 12
months of free updates are over. You can purchase one update-year for 25% of the price for
the main license (additional licenses will not be considered). Please do not hesitate to contact
us if you are interested or if you have further questions.
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